Rune Rider Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter · #1 ·
Hi All, I was on a run last week when at the ending location,someone came up to me and pointed out that the Rune was leaking coolant, there was infact a small leak coming out & down the engine near where you put the key in, I took the bike home & called the dealer which they have the bike now and are investigation it. As far as I could tell the leak was or is coming from the front top/front portion of the engine & making it's way down and around what I think is the throttle body are on the leftside if you are sitting on the bike,it's a small leak but any is to much!!. I do remember from the old board re: some hose leaks that were taking care of by tightening the clamps but I think these were the lower radiator hoses. Has anyone had anything close to this & if so what was the cause.
Thanks.
Brent
 

·
Registered
Joined
·
486 Posts
A few weeks ago I had a small spot, maybe 2-3" puddle under the middle of the bike favoring the left side. I ask my techs at the dealership, who I trust they're good. They said that it's the aluminum hose clamps, expansion and contraction from heating and cooling. Mine has not done it since. If it's persisten have the cooling system pressure tested.
 

·
Registered
Joined
·
1,556 Posts
Ok, I will admit... on my run up Pikes Peak Colorado to 13,000 feet, with a lady passenger, when I got to the top, there was ONE DROP of green coolant that was on the chrome valve cover, right side. It leaked out of the rubber coolant overflow cap.

Ken
 

·
Registered
Joined
·
127 Posts
Discussion Starter · #4 ·
Hi All, well got a call from the mechanic guru who stated that not only did I have the leak in which I found but there were 2 more smaller ones. The one I spotted was in fact at the juntion at the top part of the motor & the other two were also hoses leading to or from the cooling system, which tells me that they don't tighten them enough from the factory. Note the two smaller leaks were spotted after the system was pressure tested. Bike is leak free & I am heading out the door now to pick up the Rune,yehaaaaa!!!!!!.
 

·
Swamp Rat
Joined
·
6,989 Posts
Haven’t heard of this for a long time.

When the first Runes were delivered, 18 to 20 months ago, a large number of board members reported this, including me. What you are most likely experiencing is that the radiator hose clamps need to be tighten. That should solve the problem. Of course getting to the clamps proposes another problem.
 

·
Registered
Joined
·
852 Posts
Coolant Leak

I had a leak when I first brought my Rune home that stained the concrete in the driveway in a puddle about one-foot in diameter. Than I noticed this morning one drop on the concrete in the garage underneath my bike.
 

·
Registered
Joined
·
486 Posts
ken, I had a leak in the same place when i first got my bike, it wasn't from the reservoir, it was from a hairline crack around the nipple that the overflow hose connects to, had my dealer replace the reservoir and no problems since then.
 
1 - 7 of 7 Posts
Top